LABORATORY 4:  
INTRODUCTION TO DE2 BOARD  
BY GRZEGORZ CHMAJ

DEPARTMENT OF ELECTRICAL AND COMPUTER ENGINEERING  
UNIVERSITY OF NEVADA, LAS VEGAS

GOALS:

Getting familiar with DE2 board installation, properties, usage. Programming simple circuit using Altera Quartus.

BACKGROUND:

Altera’s DE2 Development and Education Board has been developed to provide an ideal vehicle for learning about digital logic and computer organization in a laboratory setting. It uses the state-of-the-art technology in both hardware and CAD tools to expose students to a wide range of topics covered in typical courses. The power of the board is such that it is also highly suitable for a variety of design projects as well as for the development of sophisticated digital systems. In addition to the DE2 board and the associated software, Altera provides supporting materials that include tutorials, laboratory exercises, and interesting demonstrations [1].

The DE2 board features a powerful CycloneR II FPGA chip. All important components on the board are connected to the pins of this chip, allowing the user to configure the connection between the various components as desired. For simple experiments, the DE2 board includes a sufficient number of switches (of both toggle and pushbutton variety), LEDs, and 7-segment displays. For more advanced experiments, there are SRAM, SDRAM, and Flash memory chips, as well as a 16 x 2 character display. For experiments that require a processor and simple I/O interfaces, it is easy to instantiate Altera’s Nios II processor and use interface standards such as RS-232 and PS/2. For experiments that involve sound or video signals, there are standard connectors provided on the board. For large design projects, it is possible to use USB and Ethernet connections, as well as the SD memory card. Finally, it is possible to connect other user-designed boards to the DE2 board by means of two expansion headers. Continue reading at http://faculty.unlv.edu/eelabs/docs/guides/DE2_tut_initialDE2.pdf
**Setting Up DE2 Board:**

The following procedure configures DE2 on the PC computer. Please note, that for TBE-B350 and TBE-B311 labs, the effects of this procedure will disappear when you log out of lab station computer. You have to repeat the procedure at the start of each lab if you plan to work with DE2 board.

1. Plug the DC adapter
2. Connect board using USB to the PC computer. Remember to use leftmost connector
3. Click ‘Start’, right-click ‘Computer’ and select ‘Properties’:
Click ‘Device manager’: 

You will see the list of devices, look for ‘USB-Blaster’, should be under the section ‘Other devices’:
Click ‘Update driver’:

Use ‘Browse my computer for driver software:’
Browse to: “C:\altera\71\quartus\drivers\usb-blaster\x64”

After clicking ‘Next’, the following popup can appear:

Answer “Install this driver software anyway”:
If the installation is successful, you should receive:
IMPLEMENTING SIMPLE PROJECT IN QUARTUS

In this section, it is demonstrated how to put very simple circuit to the DE2 board. Inputs will be connected to switches, output will be connected to LED.

DESIGN AN SIMULATING SCHEMATICS

1. Start Quartus II 7.1 Web Edition
2. Start new project wizard, enter the name of the project of:

   ![New Project Wizard](image)

   Click ‘Next’ twice to go to the screen – Family & Device Settings.
   Select the properties that are matching with your DE2 board. Take a look at the FPGA chip on the board to verify that below properties match with the ones you have:
   - Family: Cyclone II
   - Device: EP2C35F672C6
Click Finish.
3. Go to File -> New and select Block Diagram/Schematic File:

4. Add XOR gate to schematics:
5. Use the same panel to add input and output pins, to get the following:

![Diagram showing input and output pins connected to XOR gate]

Double click the pin to set its name (a, b – for inputs, y – for output).

6. Add simulation waveform file: go to File $\rightarrow$ New, choose Vector Waveform File:

![Screenshot showing the selection of Vector Waveform File]

![Simulator Settings window](image)

8. Run Processing -> Start Compilation and Simulation. Wait for the message about the end of the processing (*Compile and Simulation was successful*).

9. Run Processing -> Start -> Start Analysis & Synthesis.
10. Go to vector waveform view, right click the area on the left and select *Insert -> Insert Node or Bus*.

Click *Node Finder*:
Set *Filter: Pins: all*, click *List*, then click >> to add three nodes

11. Right clicking on the input waveform allows setting values. Use it to set test values for simulation, selecting either *Forcing High (1)* or *Forcing Low (0)*.
12. Run Processing -> Generate Functional Simulation Netlist.
You should get simulation results like below, confirming the operation of XOR gate:

<table>
<thead>
<tr>
<th>a</th>
<th>b</th>
<th>y</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0 – 10ns</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>10ns – 20ns</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
<td>20ns – 30ns</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>30ns – 40ns</td>
</tr>
</tbody>
</table>

Now you are sure that your schematic works as expected, as the truth table for XOR function is verified:

The next step is to put your design to the board.
PROGRAMMING DE2 BOARD

1. Assign pins. Go to Assignments -> Assignment Editor.
2. Set Category: Pin
3. Double click To field in row number 1.
4. Use the document Altera DE2 Board Pin Table
   http://faculty.unlv.edu/eelabs/docs/guides/DE2_Pin_Table.pdf to determine the relation between pin and physical element on the board. We want to use:
   Switch SW0 as first input $a$
   Switch SW1 as second input $b$
   Red LED 0 as the output.

   In the Altera DE2 Board Pin Table document, we can see, that switch SW0 is connected to pin PIN_N25:

<table>
<thead>
<tr>
<th>Signal Name</th>
<th>FPGA Pin No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SW[0]</td>
<td>PIN_N25</td>
<td>Toggle Switch[0]</td>
</tr>
</tbody>
</table>

   Thus we fill the following fields:

   Use the Altera DE2 Board Pin Table document to determine the location of two remaining elements: $b$, and $y$. You should get:

   Compile your project.
5. Make sure, that SW19 RUN/PROG switch is in the RUN position.
6. Select Tools -> Programmer. Click Hardware Setup and select USB-Blaster from drop-down list.

![Hardware Setup Window]

Close window.

7. Ensure that Mode value is set to JTAG.
8. If SOF file is not present on the list, click Add file to add it. Make sure Program/Configure checkbox is checked.

![Add File Window]

9. Click Start and wait for the board to be programmed. Observe System Messages to see if programming process ended with success.
The board is now programmed. Two switches serve as $a$, $b$ inputs to the gate, while the logic state of the output $y$ is signaled by red LED.

For more information, refer to Altera’s DE2 Board starting guide
TROUBLESHOOTING

Quartus schematics:
- Compilation errors:
  - Make sure schematic does not contain any floating elements
  - Make sure that all input and output pins are connected to the elements
- No pins showing in node finder:
  - Make sure you have performed Compilation
  - Make sure you have performed Analysis & Synthesis
- Output signal changes with delay to input signals:
  - This is probably correct – for Timing simulation. Probably you expect Functional simulation. Set that in Simulation Options.

Programming the board:
- Quartus does not see the board:
  - Make sure that USB-Blaster is installed
  - Make sure that Windows device manager indicates that USB-Blaster device works properly
  - Make sure you connected USB cable to BLASTER port on the board
- Board is visible, but there are errors while programming the board:
  - Make sure that Family and Device values are set exactly to ones that you can read from FPGA chip on your board
  - Make sure that RUN/PROG switch is in RUN position

LAB DELIVERIES:

PRELAB:

1. **Get familiar with Altera DE2 introduction documents**
   Make yourself familiar with the following documents:
   - Getting started with Altera DE2 Board:
     http://faculty.unlv.edu/eelabs/docs/guides/DE2_tut_initialDE2.pdf
   - Altera DE2 Introduction
     http://faculty.unlv.edu/eelabs/docs/guides/DE2_Introduction_box.pdf
   - Altera DE2 User Manual
   - Altera: Quartus II Introduction Using Schematic Design
     http://faculty.unlv.edu/eelabs/docs/guides/DE2_tut_quartus_intro_schem.pdf

2. **Prelab deliveries**
   Write few paragraphs about FPGA technology
LAB EXPERIMENTS:

1. **Experiment 1: Configure DE2 board in Windows system**
   Use the chapter ‘Setting up DE2 board’ from this lab instruction to setup the DE2 board. Follow the section *Implementing Simple Project In Quartus* and implement the XOR gate on the DE2 board. Demonstrate working XOR to the TA.

2. **Experiment 2: Implement light controller circuit**
   - Go through Altera DE2 tutorial, read the document with the understanding and do the steps mentioned: [http://faculty.unlv.edu/eelabs/docs/guides/DE2_tut_quartus_intro_schem.pdf](http://faculty.unlv.edu/eelabs/docs/guides/DE2_tut_quartus_intro_schem.pdf)
   - Draw the light controller circuit schematic in Quartus
   - Perform the simulation
   - Program DE2 board with this design.
   - Demonstrate working circuit to the TA.

3. **4-bit counter**
   a) Create new project, draw the 4-bit counter given below.

   ![4-bit counter diagram]

   Connect A, B, C, D to LEDR0, LEDR1, LEDR2, LEDR3.
   Connect CLK to KEY0 (note that all KEY buttons are 1 when unpressed, 0 when pressed)

   b) Use 7447 element to connect A, B, C, D to 7 segment display. Do not disconnect LEDs.
      Note that 7447 can handle only one digit, i.e. range 0-9 of the counter.
   c) EXTRA CREDIT: use two 7-segment displays to display decimal value of the counter in the range 0-15 using two digits. Use additional logic gates to implement this feature.

4. **Creating symbols**
   1. Create Full Adder
   2. Use option: “File | Create symbol” to create Full Adder as your own symbol
   3. Use your symbol to create ripple carry adder.
**POSTLAB REPORT:**

Include the following elements in the report document:

<table>
<thead>
<tr>
<th>Section</th>
<th>Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Theory of operation&lt;br&gt;<em>Include a brief description of every element and phenomenon that appears during the experiments.</em></td>
</tr>
<tr>
<td>2</td>
<td>Prelab report</td>
</tr>
<tr>
<td>3</td>
<td>Results of the experiments</td>
</tr>
<tr>
<td><strong>Experiment</strong></td>
<td><strong>Experiment Results</strong></td>
</tr>
<tr>
<td>1</td>
<td>a. Screenshot of pin assignments&lt;br&gt;b. Picture of DE2 during operation</td>
</tr>
<tr>
<td>2</td>
<td>a. Truth table&lt;br&gt;b. Screenshot of pin assignments&lt;br&gt;a. Picture of DE2 during operation</td>
</tr>
<tr>
<td>3</td>
<td>a. Screenshot of pin assignments&lt;br&gt;b. Screenshot of schematic in Quartus&lt;br&gt;a. Picture of DE2 during operation</td>
</tr>
<tr>
<td>4</td>
<td>a. Truth table&lt;br&gt;b. Screenshot of the FA schematic&lt;br&gt;c. Screenshot of the Ripple Carry circuit</td>
</tr>
<tr>
<td>4</td>
<td>Answer the questions</td>
</tr>
<tr>
<td><strong>Question no.</strong></td>
<td><strong>Question</strong></td>
</tr>
<tr>
<td>1</td>
<td>What is pin assignment in DE2?</td>
</tr>
<tr>
<td>2</td>
<td>Are pushbuttons in the DE2 active high or active low?</td>
</tr>
<tr>
<td>3</td>
<td>When connecting LEDs in DE2 board, why resistors are not used in schematic?</td>
</tr>
<tr>
<td>5</td>
<td>Conclusions&lt;br&gt;<em>Write down your conclusions, things learned, problems encountered during the lab and how they were solved, etc.</em></td>
</tr>
<tr>
<td>6</td>
<td>Attachments&lt;br&gt;<em>Zip your projects. Send through WebCampus as attachments, or provide link to the zip file on Google Drive / Dropbox, etc.</em></td>
</tr>
</tbody>
</table>

**List of attachments to deliver:**
1. Your symbol file for FA
2. Project of Ripple Carry Adder
References:

1. DE2 pin table: http://faculty.unlv.edu/eelabs/docs/guides/DE2_Pin_Table.pdf
2. Altera DE2 Introduction
   http://faculty.unlv.edu/eelabs/docs/guides/DE2_Introduction_box.pdf
3. Getting started with Altera DE2 Board:
   http://faculty.unlv.edu/eelabs/docs/guides/DE2_tut_initialDE2.pdf
4. Altera: Quartus II Introduction Using Schematic Design
   http://faculty.unlv.edu/eelabs/docs/guides/DE2_tut_quartus_intro_schem.pdf
   http://faculty.unlv.edu/eelabs/docs/guides/DE2_UserManuall.pdf
6. Datasheets of 7400 series chips:
   http://faculty.unlv.edu/eelabs/index.html?navi=main_icdatasheets